Users are unable to manage environments in Develop with AWS for Jira

Incident Report for Utoolity Apps

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 16:02 CET

Monitoring

We have deployed the missing platform updates so that AWS environments can be managed unimpeded again, and with an improved user experience. The app is now fully operational again (the ingestion of AWS build and deployment events had been unaffected throughout this incident).

We are monitoring the situation.
Posted Feb 28, 2025 - 14:08 CET

Identified

We have identified the cause of the indeed incomplete rollout of the required platform updates 2024-05-08 and are deploying a fix.
Posted Feb 28, 2025 - 13:59 CET

Update

We have verified that Develop with AWS for Compass is not affected at all and remains fully operational (the initially reported observation regarding sometimes showing the onboarding empty state turned out to be erroneous).

We continue investigating this issue and will provide updates at least every four hours, or whenever there is new information.
Posted Feb 28, 2025 - 12:50 CET

Investigating

The AWS environments configuration page shows an 'App update required' banner atop the environments table in Jira, and depending on the user's entry point, it may show the onboarding empty state rather than the environments table in Compass. The ingestion of AWS build and deployment events remains unaffected.

This error message is automatically added by Atlassian to make users aware of an imminent platform deprecation on 2025-02-28 that may require administrative approvals by some apps [1]. The apps at hand have supposedly received the required platform updates 2024-05-08 already and it is currently unclear what is causing this discrepancy.

We are currently investigating this issue and will provide updates at least every four hours, or whenever there is new information.

[1] https://developer.atlassian.com/platform/forge/changelog/#CHANGE-2297
Posted Feb 28, 2025 - 12:30 CET
This incident affected: Utoolity Apps (Develop with AWS for Jira, Develop with AWS for Compass).