Visualizations were preceded by an inaccurate error message 'App update required' in Visualize with Code / AWS for Confluence

Incident Report for Utoolity Apps

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 19:12 CET

Monitoring

We have implemented a planned improvement to the Confluence macro editor, which now renders the configuration form in a modal dialog rather than the sidebar. This enables a more interactive and versatile onboarding flow and visualization preview. As a side effect, this also removed the deprecated platform component and the misleading error message in turn.

We are monitoring the situation.
Posted Feb 25, 2025 - 18:20 CET

Update

We continue working on a fix and will provide updates at least every twelve hours, or whenever there is new information.
Posted Feb 25, 2025 - 12:12 CET

Identified

We have identified an unexpected and misleading 'App update required' error message that precedes visualizations rendered via a Confluence macro. The error message claims that the 'app version is outdated and no longer supported', which is inaccurate. Besides the added visual noise, the app remains fully operational.

This error message seems to be automatically added by Atlassian to make users aware of an imminent platform deprecation on 2025-02-28 that may require administrative approvals by some apps [1]. While this is not the case for the app at hand, there is no way for us to communicate that to Atlassian, possibly resulting in this inadvertent usability flaw.

We are working on a fix and will provide updates at least every twelve hours, or whenever there is new information.

[1] https://developer.atlassian.com/platform/forge/changelog/#CHANGE-2297
Posted Feb 24, 2025 - 19:56 CET
This incident affected: Utoolity Apps (Visualize with Code / AWS for Confluence).