Not all C4 diagrams were rendered by Visualize with AWS (Jira | Confluence)
Incident Report for Utoolity Apps
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 13:11 CET
Monitoring
All C4 diagrams are rendered correctly again after we updated the C4 diagramming component to a current version. We have also addressed the root cause of the component not being up to date in the first place, which should prevent such incidents from reoccurring.

We are monitoring the situation.
Posted Mar 19, 2024 - 23:38 CET
Update
We are still working on a fix and will provide updates at least every twelve hours, or whenever there is new information. Meanwhile you can apply the aforementioned workaround.
Posted Mar 19, 2024 - 16:12 CET
Identified
We have identified a regression in the C4 diagram rendering path, which causes many C4 diagrams to not be rendered at all. The root cause is an outdated diagramming component that lacks support for syntactical additions to the C4-PlantUML library.

We are working on a fix and will provide updates at least every twelve hours, or whenever there is new information. Meanwhile you can apply the following workaround:

WORKAROUND: Replace the version agnostic '!include <C4/C4_Container>' statement with '!include https://raw.githubusercontent.com/plantuml-stdlib/C4-PlantUML/v2.5.0/C4_Container.puml' to reference the last fully functional version 2.5.0.
Posted Mar 18, 2024 - 23:32 CET
This incident affected: Utoolity Apps (Visualize with AWS (Jira), Visualize with AWS (Confluence)).